Hyper-V 之藍

日前買了I7-860 + Asus P7H55D-M EVO + 創建 2G*4 + 400W Power

裝好 Win2008 R2 + Hyper-V 後,從舊的 4 核機器上輸出虛擬機器,然後輸入到新機器,從此不到五分鐘就會出現以下畫面,抱著遺憾睡了兩天:

 image

網路上很多傳言是 i7與 Win2k8 R2 Hyper-V 不合:

http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2virtualization/thread/a7451e42-eb42-42cf-9c3b-3bf5cc392ee0

http://social.technet.microsoft.com/Forums/zh-TW/windowsserver2008zhcht/thread/ced08e23-01bb-4663-86a0-aeb659601a73

猜測不同 CPU 的 Image 會導致 Host OS 掛掉。在本機上建立的 Hyper-V 沒問題,不必關 i7 的新功能。開著虛擬機燒機兩天後依然很穩。(在此感謝趙驚人老師對 Hyper-V 的說明)

 

好不容易證明似乎是 Hyper-V 的問題。
今晚,因為要多個 Hyper-V 一起跑,興沖沖地買了顆 500G 的 HD 加到機器裡,想要增加效能,結果,似乎 400W Power 不夠力,事情做一半就當了(不超過 10 分鐘),如同有人拔掉電源一般,一片漆黑,毀了我所做的 VSTS 2010 RC 和 SQL 2008 R2 CTP 的兩個 Hyper-V Image…
把加裝的硬碟拔出來晾在一旁,這晚上又沒了😦

 

一切復原後,早上再起來燒機,在 Hyper-V 上裝了 SQL Server 2008 + SP1,40 分鐘後又自動斷電,這次活的比較久了

但…用電過量會對 Power 留下後遺症嗎?

 

振組猜測是過熱,So…

image

結果 40 分鐘,又當了

再度進到 BIOS 把 i7 的特有功能 Intel(R) SpeedStep ( TM ) Tech 關了,並聽齊民的建議,強制風扇不准降速,至今活了一個多小時…難到…網路的傳言是真的?
要不要再把加買的硬碟放回去並裝起機殼驗證呢?…過了下星期五吧😦

最後還是當了,唉,不如睡去…有點奇怪的是,不知是否是巧合,常常 Hyper-V 因為裝軟體需要重開機時,整個就隨之當去,不過整體當的次數遠超過 Hyper-V 重開的次數…Hyper-V 重開的時候,Host 配合當。Hyper-V Run 的時候,Host 也常當…

凌晨 12:00 再度回到 Blue Screen…五天回到重前…

 

 

多日後…不執行 Hyper-V 一切沒事,很穩,但只要扯上 Hyper-V,例如透過 SCVMM 轉個 Image… 穩當 

上述純屬猜測,都沒有定論,但我不想玩了,此台不跑 Hyper-V 定讞

 

9 Comments

  1. Andrew
    Posted 2010 年 04 月 11 日 at 03:08:54 | Permalink | 回覆

    胡老師您好:我最近也是裝了一台PC也有和您一樣的問題只要跑Hyper-V就會不定時重新開機,但是沒有執行Hyper-V的時候機器又很正常,請問一下後來您這個問題有解決了嗎?謝謝

  2. 百敬
    Posted 2010 年 04 月 11 日 at 03:14:25 | Permalink | 回覆

    我最後不跑 Hyper-V,數個星期來一切正常。我想是 Hyper-V + CPU + BIOS + OS 造成不相容,等 Windows 2008 R2 Sp1 看看,不想再耗在此

  3. Andrew
    Posted 2010 年 04 月 12 日 at 01:51:38 | Permalink | 回覆

    胡老師您好:我後來有從一個日本的網站中查到一個資訊,只要把BIOS中的CPU選項中有一個是C-STATES的選項關閉就會正常,目前我已經關閉後執行hyper-v兩天了沒有重新開機的問題,讓您參考看看。

  4. 百敬
    Posted 2010 年 04 月 13 日 at 02:18:29 | Permalink | 回覆

    感謝你告知這個訊息 ^^我透過 Google Search Hyper-V C-States 得到這個網址 http://deinoscloud.wordpress.com/2009/10/22/disable-c-state-why-that/但他的 BSOD 和我的不同ㄟ不知你是否也是 Core i7

  5. Andrew
    Posted 2010 年 04 月 13 日 at 03:39:14 | Permalink | 回覆

    我也是使用i7 860,設定後就沒有問題,所以才會說可以試試看,這個好像是和OS中的進階電源管理的部份有關。

  6. 百敬
    Posted 2010 年 04 月 13 日 at 04:46:56 | Permalink | 回覆

    OK,我試試看 ^^ 多謝建議

  7. 百敬
    Posted 2010 年 04 月 13 日 at 05:28:10 | Permalink | 回覆

    40 分鐘過去了,還沒當,非常感謝你

  8. chao
    Posted 2010 年 04 月 15 日 at 14:13:40 | Permalink | 回覆

    顯卡也可能會和Hyper-V衝突,可考慮只用VGA Driver試看看http://blogs.msdn.com/virtual_pc_guy/archive/2009/11/16/understanding-high-end-video-performance-issues-with-hyper-v.aspx

  9. ringman
    Posted 2010 年 10 月 01 日 at 08:40:07 | Permalink | 回覆

    我在NB上灌 WIN2008, CPU 是 I7 720, 顯示卡是 ATI 5 系列的…在灌 WIN2008 時都沒問題, 但只要起用 Hyper-V 的角色…在重新開機就會出現藍白畫面。

    但網路上有人說把 ATI 的 DRIVER 移除在起用Hyper-V 的話,重新開機是可以的。我試過了,確實是可行的。

    但對於獨立顯卡的 3D 加速或其他特有的功能,我並不需要,我只想然解析度能夠變成 1333 * 768 這種,不知有沒有其他方式能設定…><~我找了好久…都沒找到答案..

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / 變更 )

Twitter picture

You are commenting using your Twitter account. Log Out / 變更 )

Facebook照片

You are commenting using your Facebook account. Log Out / 變更 )

Google+ photo

You are commenting using your Google+ account. Log Out / 變更 )

連結到 %s

%d 位部落客按了讚: